CVE-2018-1000301

NameCVE-2018-1000301
Descriptioncurl version curl 7.20.0 to and including curl 7.59.0 contains a CWE-126: Buffer Over-read vulnerability in denial of service that can result in curl can be tricked into reading data beyond the end of a heap based buffer used to store downloaded RTSP content.. This vulnerability appears to have been fixed in curl < 7.20.0 and curl >= 7.60.0.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1379-1, DSA-4202-1
NVD severitymedium (attack range: remote)
Debian Bugs898856

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
curl (PTS)jessie7.38.0-4+deb8u11fixed
jessie (security)7.38.0-4+deb8u14fixed
stretch (security), stretch7.52.1-5+deb9u9fixed
buster, sid7.64.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
curlsource(unstable)7.60.0-1medium898856
curlsourcejessie7.38.0-4+deb8u11mediumDSA-4202-1
curlsourcestretch7.52.1-5+deb9u6mediumDSA-4202-1
curlsourcewheezy7.26.0-1+wheezy25+deb7u1mediumDLA-1379-1

Notes

https://curl.haxx.se/docs/adv_2018-b138.html

Search for package or bug name: Reporting problems