CVE-2018-1000520

NameCVE-2018-1000520
DescriptionARM mbedTLS version 2.7.0 and earlier contains a Ciphersuite Allows Incorrectly Signed Certificates vulnerability in mbedtls_ssl_get_verify_result() that can result in ECDSA-signed certificates are accepted, when only RSA-signed ones should be.. This attack appear to be exploitable via Peers negotiate a TLS-ECDH-RSA-* ciphersuite. Any of the peers can then provide an ECDSA-signed certificate, when only an RSA-signed one should be accepted..
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mbedtls (PTS)stretch (security), stretch2.4.2-1+deb9u2vulnerable
buster, sid2.11.0-1vulnerable
polarssl (PTS)jessie (security), jessie1.3.9-2.1+deb8u3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mbedtlssource(unstable)(unfixed)low
polarsslsource(unstable)(unfixed)

Notes

[stretch] - mbedtls <no-dsa> (Minor issue)
[jessie] - polarssl <no-dsa> (Minor issue)
https://github.com/ARMmbed/mbedtls/issues/1561

Search for package or bug name: Reporting problems