CVE-2018-1000622

NameCVE-2018-1000622
DescriptionThe Rust Programming Language rustdoc version Between 0.8 and 1.27.0 contains a CWE-427: Uncontrolled Search Path Element vulnerability in rustdoc plugins that can result in local code execution as a different user. This attack appear to be exploitable via using the --plugin flag without the --plugin-path flag. This vulnerability appears to have been fixed in 1.27.1.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rustc (PTS)stretch1.34.2+dfsg1-1~deb9u1fixed
stretch (security)1.41.1+dfsg1-1~deb9u1fixed
buster1.41.1+dfsg1-1~deb10u1fixed
bullseye1.48.0+dfsg1-2fixed
bookworm, sid1.49.0+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
rustcsource(unstable)1.27.1+dfsg1-1~exp1

Notes

[stretch] - rustc <ignored> (Minor issue, can be fixed along in future rustc update for ESR69)
[jessie] - rustc <ignored> (Minor issue)
https://groups.google.com/forum/#!topic/rustlang-security-announcements/4ybxYLTtXuM

Search for package or bug name: Reporting problems