CVE-2018-1000657

NameCVE-2018-1000657
DescriptionRust Programming Language Rust standard library version Commit bfa0e1f58acf1c28d500c34ed258f09ae021893e and later; stable release 1.3.0 and later contains a Buffer Overflow vulnerability in std::collections::vec_deque::VecDeque::reserve() function that can result in Arbitrary code execution, but no proof-of-concept exploit is currently published.. This vulnerability appears to have been fixed in after commit fdfafb510b1a38f727e920dccbeeb638d39a8e60; stable release 1.22.0 and later.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs906585

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rustc (PTS)stretch1.34.2+dfsg1-1~deb9u1fixed
stretch (security)1.41.1+dfsg1-1~deb9u1fixed
buster1.41.1+dfsg1-1~deb10u1fixed
bullseye1.48.0+dfsg1-2fixed
bookworm, sid1.49.0+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
rustcsource(unstable)1.22.1+dfsg1-1906585

Notes

Introduced by: https://github.com/rust-lang/rust/commit/bfa0e1f58acf1c28d500c34ed258f09ae021893e (1.3.0)
Fixed by: https://github.com/rust-lang/rust/commit/f71b37bc28326e272a37b938e835d4f99113eec2 (1.22.0)
https://github.com/rust-lang/rust/issues/44800

Search for package or bug name: Reporting problems