DescriptionWordPress version 4.9.8 and earlier contains a CWE-20 Input Validation vulnerability in thumbnail processing that can result in remote code execution due to an incomplete fix for CVE-2017-1000600. This attack appears to be exploitable via thumbnail upload by an authenticated user and may require additional plugins in order to be exploited however this has not been confirmed at this time.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)jessie4.1+dfsg-1+deb8u17vulnerable
jessie (security)4.1.31+dfsg-0+deb8u1vulnerable
stretch (security)4.7.5+dfsg-2+deb9u6vulnerable
buster (security)5.0.10+dfsg1-0+deb10u1vulnerable
bullseye, sid5.4.2+dfsg1-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


[jessie] - wordpress <postponed> (cf. CVE-2017-1000600)
This CVE exists due to an incomplete fix in 4.9 for CVE-2017-1000600.

Search for package or bug name: Reporting problems