CVE-2018-1000805

NameCVE-2018-1000805
DescriptionParamiko version 2.4.1, 2.3.2, 2.2.3, 2.1.5, 2.0.8, 1.18.5, 1.17.6 contains a Incorrect Access Control vulnerability in SSH server that can result in RCE. This attack appear to be exploitable via network connectivity.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-1556-1, DLA-2860-1
Debian Bugs910760

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
paramiko (PTS)buster2.4.2-0.1fixed
buster (security)2.4.2-0.1+deb10u1fixed
bullseye2.7.2-1fixed
bookworm2.12.0-2fixed
sid, trixie3.4.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
paramikosourcejessie1.15.1-1+deb8u1DLA-1556-1
paramikosourcestretch2.0.0-1+deb9u1DLA-2860-1
paramikosource(unstable)2.4.2-0.1910760

Notes

https://github.com/paramiko/paramiko/issues/1283
https://github.com/paramiko/paramiko/commit/56c96a659658acdbb873aef8809a7b508434dcce

Search for package or bug name: Reporting problems