CVE-2018-10058

NameCVE-2018-10058
DescriptionThe remote management interface of cgminer 4.10.0 and bfgminer 5.5.0 allows an authenticated remote attacker to execute arbitrary code due to a stack-based buffer overflow in the addpool, failover-only, poolquota, and save command handlers.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs900929, 900930

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
bfgminer (PTS)jessie4.7.0+dfsg-2vulnerable
sid5.4.2+dfsg-1vulnerable
cgminer (PTS)jessie4.7.0-2vulnerable
sid, stretch4.9.2-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
bfgminersource(unstable)(unfixed)medium900930
cgminersource(unstable)(unfixed)medium900929

Notes

[stretch] - cgminer <no-dsa> (Minor issue)
[jessie] - cgminer <no-dsa> (Minor issue)
[jessie] - bfgminer <no-dsa> (Minor issue)
http://www.openwall.com/lists/oss-security/2018/06/03/1
Mitigated by toolchain hardening to plain crash

Search for package or bug name: Reporting problems