CVE-2018-10059

NameCVE-2018-10059
DescriptionCacti before 1.1.37 has XSS because the get_current_page function in lib/functions.php relies on $_SERVER['PHP_SELF'] instead of $_SERVER['SCRIPT_NAME'] to determine a page name.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cacti (PTS)stretch (security), stretch0.8.8h+ds1-10+deb9u1fixed
buster1.2.2+ds1-2+deb10u4fixed
buster (security)1.2.2+ds1-2+deb10u2fixed
bullseye, sid1.2.16+ds1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cactisourcewheezy(not affected)
cactisourcejessie(not affected)
cactisourcestretch(not affected)
cactisource(unstable)1.1.37+ds1-1

Notes

[stretch] - cacti <not-affected> (Issue introduced later)
[jessie] - cacti <not-affected> (Issue introduced later)
[wheezy] - cacti <not-affected> (Issue introduced later)
https://github.com/Cacti/cacti/issues/1457
get_current_page was added in the 1.x series

Search for package or bug name: Reporting problems