CVE-2018-10060

NameCVE-2018-10060
DescriptionCacti before 1.1.37 has XSS because it does not properly reject unintended characters, related to use of the sanitize_uri function in lib/functions.php.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2965-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cacti (PTS)buster1.2.2+ds1-2+deb10u4fixed
buster (security)1.2.2+ds1-2+deb10u2fixed
bullseye1.2.16+ds1-2fixed
bookworm, sid1.2.21+ds1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cactisourcestretch0.8.8h+ds1-10+deb9u2DLA-2965-1
cactisource(unstable)1.1.37+ds1-1low

Notes

[jessie] - cacti <no-dsa> (Minor issue)
[wheezy] - cacti <no-dsa> (Minor issue)
https://github.com/Cacti/cacti/issues/1457
https://github.com/Cacti/cacti/commit/ddaec1c5ac2dc759a201feecbc91698e7bbeefba (v1.1.37)
https://github.com/Cacti/cacti/commit/a02f223f4e9427b0411a3f25672fd86764e63b54 (v1.1.37)
https://github.com/Cacti/cacti/commit/3ba47881c5f8f6a01606a5afd4f1934e32d97e92 (v1.1.37)
https://github.com/Cacti/cacti/commit/1707956caa2c854cbcf684a33d108519e89a5909 (v1.1.37)

Search for package or bug name: Reporting problems