CVE-2018-10061

NameCVE-2018-10061
DescriptionCacti before 1.1.37 has XSS because it makes certain htmlspecialchars calls without the ENT_QUOTES flag (these calls occur when the html_escape function in lib/html.php is not used).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cacti (PTS)jessie0.8.8b+dfsg-8+deb8u6vulnerable
jessie (security)0.8.8b+dfsg-8+deb8u9vulnerable
stretch, stretch (security)0.8.8h+ds1-10+deb9u1vulnerable
buster, buster (security)1.2.2+ds1-2+deb10u2fixed
bullseye, sid1.2.10+ds1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cactisource(unstable)1.1.37+ds1-1low

Notes

[stretch] - cacti <no-dsa> (Minor issue)
[jessie] - cacti <no-dsa> (Minor issue)
[wheezy] - cacti <no-dsa> (Minor issue)
https://github.com/Cacti/cacti/issues/1457

Search for package or bug name: Reporting problems