CVE-2018-10101

NameCVE-2018-10101
DescriptionBefore WordPress 4.9.5, the URL validator assumed URLs with the hostname localhost were on the same host as the WordPress server.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs895034

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)jessie4.1+dfsg-1+deb8u17fixed
jessie (security)4.1+dfsg-1+deb8u18fixed
stretch4.7.5+dfsg-2+deb9u3fixed
stretch (security)4.7.5+dfsg-2+deb9u4fixed
buster, sid4.9.8+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssource(unstable)4.9.5+dfsg1-1medium895034
wordpresssourcejessie(not affected)
wordpresssourcestretch4.7.5+dfsg-2+deb9u3medium
wordpresssourcewheezy(not affected)

Notes

[jessie] - wordpress <not-affected> (vulnerable code is not present)
[wheezy] - wordpress <not-affected> (vulnerable code is not present)
https://core.trac.wordpress.org/changeset/42894
https://github.com/WordPress/WordPress/commit/804363859602d4050d9a38a21f5a65d9aec18216
Introduced via https://github.com/WordPress/WordPress/commit/c73a812109e1a64ecf21b6a198f949c58d1f2674 (4.5)

Search for package or bug name: Reporting problems