CVE-2018-10188

NameCVE-2018-10188
DescriptionphpMyAdmin 4.8.0 before 4.8.0-1 has CSRF, allowing an attacker to execute arbitrary SQL statements, related to js/db_operations.js, js/tbl_operations.js, libraries/classes/Operations.php, and sql.php.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs896490

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
phpmyadmin (PTS)stretch4:4.6.6-4+deb9u1fixed
stretch (security)4:4.6.6-4+deb9u2fixed
bullseye4:5.0.4+dfsg2-2fixed
bookworm, sid4:5.1.1+dfsg1-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
phpmyadminsourcewheezy(not affected)
phpmyadminsourcejessie(not affected)
phpmyadminsourcestretch(not affected)
phpmyadminsource(unstable)4:4.9.1+dfsg1-2896490

Notes

[stretch] - phpmyadmin <not-affected> (Only affects 4.8.x)
[jessie] - phpmyadmin <not-affected> (vulnerable code not present)
[wheezy] - phpmyadmin <not-affected> (vulnerable code not present)
https://www.phpmyadmin.net/security/PMASA-2018-2/
https://github.com/phpmyadmin/phpmyadmin/commit/c6dd6b56e236a3aff953cee4135ecaa67130e641

Search for package or bug name: Reporting problems