CVE-2018-10191

NameCVE-2018-10191
DescriptionIn versions of mruby up to and including 1.4.0, an integer overflow exists in src/vm.c::mrb_vm_exec() when handling OP_GETUPVAR in the presence of deep scope nesting, resulting in a use-after-free. An attacker that can cause Ruby code to be run can use this to possibly execute arbitrary code.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs896020

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mruby (PTS)jessie1.0.0+20141015+gitb4cc962c-1vulnerable
stretch1.2.0+20161228+git30d5424a-1vulnerable
bullseye, sid, buster2.0.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mrubysource(unstable)1.4.0+20180418+git54905e98-1high896020

Notes

[stretch] - mruby <no-dsa> (Minor issue)
[jessie] - mruby <no-dsa> (Minor issue)
https://github.com/mruby/mruby/issues/3995
https://github.com/mruby/mruby/commit/1905091634a6a2925c911484434448e568330626

Search for package or bug name: Reporting problems