CVE-2018-10194

NameCVE-2018-10194
DescriptionThe set_text_distance function in devices/vector/gdevpdts.c in the pdfwrite component in Artifex Ghostscript through 9.22 does not prevent overflows in text-positioning calculation, which allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted PDF document.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1363-1
NVD severitymedium (attack range: remote)
Debian Bugs896069

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ghostscript (PTS)jessie9.06~dfsg-2+deb8u7fixed
jessie (security)9.06~dfsg-2+deb8u13fixed
stretch9.20~dfsg-3.2+deb9u5fixed
stretch (security)9.26~dfsg-0+deb9u2fixed
buster, sid9.26~dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ghostscriptsource(unstable)9.22~dfsg-2.1medium896069
ghostscriptsourcejessie9.06~dfsg-2+deb8u7medium
ghostscriptsourcestretch9.20~dfsg-3.2+deb9u2medium
ghostscriptsourcewheezy9.05~dfsg-6.3+deb7u8mediumDLA-1363-1

Notes

http://git.ghostscript.com/?p=ghostpdl.git;a=commit;h=39b1e54b2968620723bf32e96764c88797714879
https://bugs.ghostscript.com/show_bug.cgi?id=699255 (not yet public)

Search for package or bug name: Reporting problems