CVE-2018-10242

NameCVE-2018-10242
DescriptionSuricata version 4.0.4 incorrectly handles the parsing of the SSH banner. A malformed SSH banner can cause the parsing code to read beyond the allocated data because SSHParseBanner in app-layer-ssh.c lacks a length check.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1751-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
suricata (PTS)jessie2.0.7-2+deb8u1vulnerable
jessie (security)2.0.7-2+deb8u4fixed
stretch3.2.1-1+deb9u1vulnerable
buster1:4.1.2-2fixed
bullseye, sid1:4.1.5-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
suricatasource(unstable)1:4.0.5-1
suricatasourcejessie2.0.7-2+deb8u4DLA-1751-1

Notes

[stretch] - suricata <no-dsa> (Minor issue)
https://redmine.openinfosecfoundation.org/issues/2544
https://redmine.openinfosecfoundation.org/issues/2542
https://github.com/OISF/suricata/commit/9ba89a31efc89ec5cb72326dbcb9166b098f3ea0
https://suricata-ids.org/2018/07/18/suricata-4-0-5-available/

Search for package or bug name: Reporting problems