CVE-2018-10243

NameCVE-2018-10243
Descriptionhtp_parse_authorization_digest in htp_parsers.c in LibHTP 0.5.26 allows remote attackers to cause a heap-based buffer over-read via an authorization digest header.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1751-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libhtp (PTS)buster, sid1:0.5.30-1fixed
suricata (PTS)jessie2.0.7-2+deb8u1vulnerable
jessie (security)2.0.7-2+deb8u4fixed
stretch3.2.1-1+deb9u1vulnerable
buster1:4.1.2-2fixed
sid1:4.1.4-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libhtpsource(unstable)1:0.5.28-1high
suricatasource(unstable)1:4.0.0-1high
suricatasourcejessie2.0.7-2+deb8u4highDLA-1751-1

Notes

[stretch] - suricata <no-dsa> (Minor issue)
suricata used the embedded copy of libhtp up to before 1:4.0.0-1.
https://github.com/OISF/libhtp/issues/169
https://github.com/OISF/libhtp/commit/eefd4b7d2be663f6067362f29c81e6edf909145a
https://suricata-ids.org/2018/07/18/suricata-4-0-5-available/

Search for package or bug name: Reporting problems