CVE-2018-10244

NameCVE-2018-10244
DescriptionSuricata version 4.0.4 incorrectly handles the parsing of an EtherNet/IP PDU. A malformed PDU can cause the parsing code to read beyond the allocated data because DecodeENIPPDU in app-layer-enip-commmon.c has an integer overflow during a length check.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
suricata (PTS)jessie2.0.7-2+deb8u1fixed
jessie (security)2.0.7-2+deb8u4fixed
stretch3.2.1-1+deb9u1vulnerable
buster1:4.1.2-2fixed
bullseye1:4.1.4-2fixed
sid1:4.1.4-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
suricatasource(unstable)1:4.0.5-1high
suricatasourcejessie(not affected)

Notes

[stretch] - suricata <no-dsa> (Minor issue)
[jessie] - suricata <not-affected> (EtherNet/IP and CIP support introduced in 3.2beta1)
https://redmine.openinfosecfoundation.org/issues/2545
https://redmine.openinfosecfoundation.org/issues/2543
https://github.com/OISF/suricata/commit/f68bf3301ad4d25f0a5ecb13405f4e26316cdf8d
https://suricata-ids.org/2018/07/18/suricata-4-0-5-available/

Search for package or bug name: Reporting problems