CVE-2018-10471

NameCVE-2018-10471
DescriptionAn issue was discovered in Xen through 4.10.x allowing x86 PV guest OS users to cause a denial of service (out-of-bounds zero write and hypervisor crash) via unexpected INT 80 processing, because of an incorrect fix for CVE-2017-5754.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4201-1
NVD severitymedium (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xen (PTS)jessie4.4.1-9+deb8u10vulnerable
jessie (security)4.4.4lts1-0+deb8u1vulnerable
buster, sid, stretch4.8.3+xsa267+shim4.10.1+xsa267-1+deb9u9fixed
stretch (security)4.8.4+xsa273+shim4.10.1+xsa273-1+deb9u10fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xensource(unstable)4.8.3+xsa262+shim4.10.0+comet3-1+deb9u6medium
xensourcestretch4.8.3+xsa262+shim4.10.0+comet3-1+deb9u6mediumDSA-4201-1
xensourcewheezy(not affected)

Notes

[wheezy] - xen <not-affected> (Regression for XSA-254 which was not applied in wheezy)
https://xenbits.xen.org/xsa/advisory-259.html

Search for package or bug name: Reporting problems