CVE-2018-10529

NameCVE-2018-10529
DescriptionAn issue was discovered in LibRaw 0.18.9. There is an out-of-bounds read affecting the X3F property table list implementation in libraw_x3f.cpp and libraw_cxx.cpp.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs897186

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libraw (PTS)buster0.19.2-2fixed
buster (security)0.19.2-2+deb10u3fixed
bullseye0.20.2-1fixed
bullseye (security)0.20.2-1+deb11u1fixed
bookworm, sid0.20.2-2.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
librawsource(unstable)0.18.11-1low897186

Notes

[wheezy] - libraw <no-dsa> (Minor issue)
https://github.com/LibRaw/LibRaw/commit/f0c505a3e5d47989a5f69be2d0d4f250af6b1a6c
https://github.com/LibRaw/LibRaw/issues/144

Search for package or bug name: Reporting problems