CVE-2018-10537

NameCVE-2018-10537
DescriptionAn issue was discovered in WavPack 5.1.0 and earlier. The W64 parser component contains a vulnerability that allows writing to memory because ParseWave64HeaderConfig in wave64.c does not reject multiple format chunks.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4197-1
Debian Bugs897271

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wavpack (PTS)wheezy4.60.1-3fixed
jessie4.70.0-1fixed
stretch5.0.0-2+deb9u1vulnerable
stretch (security)5.0.0-2+deb9u2fixed
buster, sid5.1.0-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wavpacksource(unstable)5.1.0-3897271
wavpacksourcejessie(not affected)
wavpacksourcestretch5.0.0-2+deb9u2DSA-4197-1
wavpacksourcewheezy(not affected)

Notes

[jessie] - wavpack <not-affected> (Vulnerable code not present, introduced in 5.0.0)
[wheezy] - wavpack <not-affected> (Vulnerable code not present, introduced in 5.0.0)
https://github.com/dbry/WavPack/commit/26cb47f99d481ad9b93eeff80d26e6b63bbd7e15
https://github.com/dbry/WavPack/issues/30
https://github.com/dbry/WavPack/issues/31
https://github.com/dbry/WavPack/issues/32

Search for package or bug name: Reporting problems