CVE-2018-10540

NameCVE-2018-10540
DescriptionAn issue was discovered in WavPack 5.1.0 and earlier for W64 input. Out-of-bounds writes can occur because ParseWave64HeaderConfig in wave64.c does not validate the sizes of unknown chunks before attempting memory allocation, related to a lack of integer-overflow protection within a bytes_to_copy calculation and subsequent malloc call, leading to insufficient memory allocation.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4197-1
NVD severitymedium (attack range: remote)
Debian Bugs897271

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wavpack (PTS)jessie4.70.0-1fixed
stretch, stretch (security)5.0.0-2+deb9u2fixed
buster, sid5.1.0-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wavpacksource(unstable)5.1.0-3medium897271
wavpacksourcejessie(not affected)
wavpacksourcestretch5.0.0-2+deb9u2mediumDSA-4197-1
wavpacksourcewheezy(not affected)

Notes

[jessie] - wavpack <not-affected> (Vulnerable code not present, introduced in 5.0.0)
[wheezy] - wavpack <not-affected> (Vulnerable code not present, introduced in 5.0.0)
https://github.com/dbry/WavPack/commit/6f8bb34c2993a48ab9afbe353e6d0cff7c8d821d
https://github.com/dbry/WavPack/issues/33

Search for package or bug name: Reporting problems