CVE-2018-1066

NameCVE-2018-1066
DescriptionThe Linux kernel before version 4.11 is vulnerable to a NULL pointer dereference in fs/cifs/cifsencrypt.c:setup_ntlmv2_rsp() that allows an attacker controlling a CIFS server to kernel panic a client that has this server mounted, because an empty TargetInfo field in an NTLMSSP setup negotiation response is mishandled during session recovery.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4187-1, DSA-4188-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)jessie3.16.51-2vulnerable
jessie (security)3.16.56-1+deb8u1fixed
stretch4.9.82-1+deb9u3vulnerable
stretch (security)4.9.88-1+deb9u1fixed
buster4.16.12-1fixed
sid4.16.16-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)4.11.6-1high
linuxsourcejessie3.16.56-1highDSA-4187-1
linuxsourcestretch4.9.88-1highDSA-4188-1
linuxsourcewheezy(not affected)

Notes

[wheezy] - linux <not-affected> (Vulnerable code not present)
Fixed by: https://git.kernel.org/linus/cabfb3680f78981d26c078a26e5c748531257ebb

Search for package or bug name: Reporting problems