CVE-2018-10768

NameCVE-2018-10768
DescriptionThere is a NULL pointer dereference in the AnnotPath::getCoordsLength function in Annot.h in an Ubuntu package for Poppler 0.24.5. A crafted input will lead to a remote denial of service attack. Later Ubuntu packages such as for Poppler 0.41.0 are not affected.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1562-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
poppler (PTS)stretch0.48.0-2+deb9u2fixed
stretch (security)0.48.0-2+deb9u3fixed
buster0.71.0-5fixed
bullseye, sid20.09.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
popplersourcewheezy(not affected)
popplersourcejessie0.26.5-2+deb8u5DLA-1562-1
popplersource(unstable)0.38.0-2

Notes

[wheezy] - poppler <not-affected> (Vulnerable code is not present)
https://bugs.freedesktop.org/show_bug.cgi?id=106408
Fixed by: https://cgit.freedesktop.org/poppler/poppler/commit/?id=942adfc25e7a00ac3cf032ced2d8949e99099f70 (poppler-0.37)

Search for package or bug name: Reporting problems