CVE-2018-10811

NameCVE-2018-10811
DescriptionstrongSwan 5.6.0 and older allows Remote Denial of Service because of Missing Initialization of a Variable.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4229-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
strongswan (PTS)jessie (security), jessie5.2.1-6+deb8u6fixed
stretch (security), stretch5.5.1-4+deb9u2fixed
buster, sid5.6.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
strongswansource(unstable)5.6.3-1medium
strongswansourcejessie5.2.1-6+deb8u6mediumDSA-4229-1
strongswansourcestretch5.5.1-4+deb9u2mediumDSA-4229-1

Notes

https://www.strongswan.org/blog/2018/05/28/strongswan-5.6.3-released.html
https://www.strongswan.org/blog/2018/05/28/strongswan-vulnerability-(cve-2018-10811).html

Search for package or bug name: Reporting problems