CVE-2018-10839

NameCVE-2018-10839
DescriptionQemu emulator <= 3.0.0 built with the NE2000 NIC emulation support is vulnerable to an integer overflow, which could lead to buffer overflow issue. It could occur when receiving packets over the network. A user inside guest could use this flaw to crash the Qemu process resulting in DoS.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1599-1, DSA-4338-1
Debian Bugs910431

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)jessie1:2.1+dfsg-12+deb8u6vulnerable
jessie (security)1:2.1+dfsg-12+deb8u8fixed
stretch1:2.8+dfsg-6+deb9u4vulnerable
stretch (security)1:2.8+dfsg-6+deb9u5fixed
buster1:2.12+dfsg-3vulnerable
sid1:3.1+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusource(unstable)1:3.1+dfsg-1910431
qemusourcejessie1:2.1+dfsg-12+deb8u8DLA-1599-1
qemusourcestretch1:2.8+dfsg-6+deb9u5DSA-4338-1
qemu-kvmsource(unstable)(unfixed)

Notes

https://lists.gnu.org/archive/html/qemu-devel/2018-09/msg03273.html
https://www.openwall.com/lists/oss-security/2018/10/08/1
https://git.qemu.org/?p=qemu.git;a=commit;h=fdc89e90fac40c5ca2686733df17b6423fb8d8fb

Search for package or bug name: Reporting problems