CVE-2018-10850

NameCVE-2018-10850
Description389-ds-base before versions 1.4.0.10, 1.3.8.3 is vulnerable to a race condition in the way 389-ds-base handles persistent search, resulting in a crash if the server is under load. An anonymous attacker could use this flaw to trigger a denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1428-1
NVD severityhigh (attack range: remote)
Debian Bugs903501

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
389-ds-base (PTS)jessie1.3.3.5-4vulnerable
jessie (security)1.3.3.5-4+deb8u2fixed
stretch1.3.5.17-2vulnerable
sid1.4.0.15-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
389-ds-basesource(unstable)1.4.0.15-1high903501
389-ds-basesourceexperimental1.4.0.13-1high
389-ds-basesourcejessie1.3.3.5-4+deb8u1highDLA-1428-1

Notes

https://bugzilla.redhat.com/show_bug.cgi?id=1588056
https://pagure.io/389-ds-base/c/8f04487f99a
https://pagure.io/389-ds-base/issue/49768

Search for package or bug name: Reporting problems