CVE-2018-10851

NameCVE-2018-10851
DescriptionPowerDNS Authoritative Server 3.3.0 up to 4.1.4 excluding 4.1.5 and 4.0.6, and PowerDNS Recursor 3.2 up to 4.1.4 excluding 4.1.5 and 4.0.9, are vulnerable to a memory leak while parsing malformed records that can lead to remote denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs913162, 913163

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pdns (PTS)jessie3.4.1-4+deb8u8vulnerable
jessie (security)3.4.1-4+deb8u10vulnerable
stretch4.0.3-1+deb9u4fixed
stretch (security)4.0.3-1+deb9u5fixed
bullseye, sid, buster4.1.6-3fixed
pdns-recursor (PTS)jessie3.6.2-2+deb8u4vulnerable
jessie (security)3.6.2-2+deb8u3vulnerable
stretch4.0.4-1+deb9u4fixed
stretch (security)4.0.4-1+deb9u3vulnerable
buster4.1.11-1fixed
bullseye, sid4.2.0-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pdnssource(unstable)4.1.5-1medium913163
pdnssourcestretch4.0.3-1+deb9u3medium
pdns-recursorsource(unstable)4.1.7-1medium913162
pdns-recursorsourcestretch4.0.4-1+deb9u4medium

Notes

[jessie] - pdns <ignored> (Minor issue)
[jessie] - pdns-recursor <ignored> (Minor issue)
https://doc.powerdns.com/authoritative/security-advisories/powerdns-advisory-2018-03.html
https://downloads.powerdns.com/patches/2018-03/
https://doc.powerdns.com/recursor/security-advisories/powerdns-advisory-2018-04.html
https://downloads.powerdns.com/patches/2018-04/

Search for package or bug name: Reporting problems