DescriptionPowerDNS Authoritative Server 3.3.0 up to 4.1.4 excluding 4.1.5 and 4.0.6, and PowerDNS Recursor 3.2 up to 4.1.4 excluding 4.1.5 and 4.0.9, are vulnerable to a memory leak while parsing malformed records that can lead to remote denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs913162, 913163

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pdns (PTS)jessie3.4.1-4+deb8u8vulnerable
jessie (security)3.4.1-4+deb8u7vulnerable
buster, sid4.1.5-1fixed
pdns-recursor (PTS)jessie3.6.2-2+deb8u4vulnerable
jessie (security)3.6.2-2+deb8u3vulnerable
stretch (security), stretch4.0.4-1+deb9u3vulnerable
buster, sid4.1.8-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


[stretch] - pdns <no-dsa> (Minor issue; will be fixed via point release)
[jessie] - pdns <ignored> (Minor issue)
[stretch] - pdns-recursor <no-dsa> (Minor issue)
[jessie] - pdns-recursor <ignored> (Minor issue)

Search for package or bug name: Reporting problems