CVE-2018-10853

NameCVE-2018-10853
DescriptionA flaw was found in the way Linux kernel KVM hypervisor before 4.18 emulated instructions such as sgdt/sidt/fxsave/fxrstor. It did not check current privilege(CPL) level while emulating unprivileged instructions. An unprivileged guest user/process could use this flaw to potentially escalate privileges inside guest.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1422-1, DLA-1423-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)jessie3.16.56-1+deb8u1vulnerable
jessie (security)3.16.59-1fixed
stretch4.9.110-1fixed
stretch (security)4.9.110-3+deb9u6fixed
buster, sid4.18.10-2fixed
linux-4.9 (PTS)jessie (security)4.9.110-3+deb9u5~deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)4.16.16-1
linuxsourcejessie3.16.57-1DLA-1422-1
linuxsourcestretch4.9.110-1
linux-4.9sourcejessie4.9.110-1~deb8u1DLA-1423-1

Notes

Fixed by: https://git.kernel.org/linus/3c9fa24ca7c9c47605672916491f79e8ccacb9e6

Search for package or bug name: Reporting problems