CVE-2018-10858

NameCVE-2018-10858
DescriptionA heap-buffer overflow was found in the way samba clients processed extra long filename in a directory listing. A malicious samba server could use this flaw to cause arbitrary code execution on a samba client. Samba versions before 4.6.16, 4.7.9 and 4.8.4 are vulnerable.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1539-1, DSA-4271-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
samba (PTS)jessie2:4.2.14+dfsg-0+deb8u9vulnerable
jessie (security)2:4.2.14+dfsg-0+deb8u13fixed
stretch (security), stretch2:4.5.16+dfsg-1+deb9u2fixed
buster2:4.9.5+dfsg-5fixed
buster (security)2:4.9.5+dfsg-5+deb10u1fixed
bullseye2:4.9.13+dfsg-1fixed
sid2:4.10.8+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sambasource(unstable)2:4.8.4+dfsg-1medium
sambasourcejessie2:4.2.14+dfsg-0+deb8u10mediumDLA-1539-1
sambasourcestretch2:4.5.12+dfsg-2+deb9u3mediumDSA-4271-1

Notes

https://www.samba.org/samba/security/CVE-2018-10858.html

Search for package or bug name: Reporting problems