CVE-2018-10871

NameCVE-2018-10871
Description389-ds-base before versions 1.3.8.5, 1.4.0.12 is vulnerable to a Cleartext Storage of Sensitive Information. By default, when the Replica and/or retroChangeLog plugins are enabled, 389-ds-base stores passwords in plaintext format in their respective changelog files. An attacker with sufficiently high privileges, such as root or Directory Manager, can query these files in order to retrieve plaintext passwords.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1483-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
389-ds-base (PTS)jessie1.3.3.5-4vulnerable
jessie (security)1.3.3.5-4+deb8u5fixed
stretch1.3.5.17-2vulnerable
sid1.4.0.19-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
389-ds-basesource(unstable)1.4.0.15-1medium
389-ds-basesourceexperimental1.4.0.13-1medium
389-ds-basesourcejessie1.3.3.5-4+deb8u2mediumDLA-1483-1

Notes

https://pagure.io/389-ds-base/issue/49789

Search for package or bug name: Reporting problems