CVE-2018-10888

NameCVE-2018-10888
DescriptionA flaw was found in libgit2 before version 0.27.3. A missing check in git_delta_apply function in delta.c file, may lead to an out-of-bound read while reading a binary delta file. An attacker may use this flaw to cause a Denial of Service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1477-1
NVD severitymedium (attack range: remote)
Debian Bugs903508

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libgit2 (PTS)jessie0.21.1-3vulnerable
jessie (security)0.21.1-3+deb8u1fixed
stretch0.25.1+really0.24.6-1vulnerable
buster, sid0.27.4+dfsg.1-0.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libgit2source(unstable)0.27.4+dfsg.1-0.1low903508
libgit2sourcejessie0.21.1-3+deb8u1mediumDLA-1477-1

Notes

[stretch] - libgit2 <no-dsa> (Minor issue)
https://github.com/libgit2/libgit2/commit/9844d38bed10e9ff17174434b3421b227ae710f3

Search for package or bug name: Reporting problems