CVE-2018-10895

NameCVE-2018-10895
Descriptionqutebrowser before version 1.4.1 is vulnerable to a cross-site request forgery flaw that allows websites to access 'qute://*' URLs. A malicious website could exploit this to load a 'qute://settings/set' URL, which then sets 'editor.command' to a bash script, resulting in arbitrary code execution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qutebrowser (PTS)buster, sid1.4.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qutebrowsersource(unstable)1.4.1-1medium

Notes

http://www.openwall.com/lists/oss-security/2018/07/11/7
https://github.com/qutebrowser/qutebrowser/issues/4060
Introduced in: https://github.com/qutebrowser/qutebrowser/commit/ffc29ee (v1.0.0)
Fixed in: https://github.com/qutebrowser/qutebrowser/commit/43e58ac865ff862c2008c510fc5f7627e10b4660 (v1.4.1)

Search for package or bug name: Reporting problems