CVE-2018-10918

NameCVE-2018-10918
DescriptionA null pointer dereference flaw was found in the way samba checked database outputs from the LDB database layer. An authenticated attacker could use this flaw to crash a samba server in an Active Directory Domain Controller configuration. Samba versions before 4.7.9 and 4.8.4 are vulnerable.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
samba (PTS)stretch2:4.5.16+dfsg-1+deb9u2fixed
stretch (security)2:4.5.16+dfsg-1+deb9u4fixed
buster2:4.9.5+dfsg-5fixed
buster (security)2:4.9.5+dfsg-5+deb10u2fixed
bullseye (security), bullseye2:4.13.13+dfsg-1~deb11u2fixed
bookworm, sid2:4.13.14+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sambasourcejessie(not affected)
sambasourcestretch(not affected)
sambasource(unstable)2:4.8.4+dfsg-1

Notes

[stretch] - samba <not-affected> (Only affects Samba 4.7.0 onwards)
[jessie] - samba <not-affected> (Only affects Samba 4.7.0 onwards)
https://www.samba.org/samba/security/CVE-2018-10918.html

Search for package or bug name: Reporting problems