CVE-2018-10982

NameCVE-2018-10982
DescriptionAn issue was discovered in Xen through 4.10.x allowing x86 HVM guest OS users to cause a denial of service (unexpectedly high interrupt number, array overrun, and hypervisor crash) or possibly gain hypervisor privileges by setting up an HPET timer to deliver interrupts in IO-APIC mode, aka vHPET interrupt injection.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4201-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xen (PTS)wheezy4.1.4-3+deb7u9vulnerable
wheezy (security)4.1.6.lts1-13vulnerable
jessie (security), jessie4.4.1-9+deb8u10vulnerable
buster, sid, stretch4.8.3+comet2+shim4.10.0+comet3-1+deb9u5vulnerable
stretch (security)4.8.3+xsa262+shim4.10.0+comet3-1+deb9u6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xensource(unstable)(unfixed)
xensourcestretch4.8.3+xsa262+shim4.10.0+comet3-1+deb9u6DSA-4201-1

Notes

https://xenbits.xen.org/xsa/advisory-261.html

Search for package or bug name: Reporting problems