CVE-2018-10998

NameCVE-2018-10998
DescriptionAn issue was discovered in Exiv2 0.26. readMetadata in jp2image.cpp allows remote attackers to cause a denial of service (SIGABRT) by triggering an incorrect Safe::add call.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1402-1, DSA-4238-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
exiv2 (PTS)jessie0.24-4.1vulnerable
jessie (security)0.24-4.1+deb8u1fixed
stretch (security), stretch0.25-3.1+deb9u1fixed
buster, sid0.25-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
exiv2source(unstable)0.25-4medium
exiv2sourcejessie0.24-4.1+deb8u1mediumDLA-1402-1
exiv2sourcestretch0.25-3.1+deb9u1mediumDSA-4238-1

Notes

https://github.com/Exiv2/exiv2/issues/303
https://github.com/Exiv2/exiv2/commit/f4e8ed2fd48d012467b99552f0d6378302a23c75

Search for package or bug name: Reporting problems