CVE-2018-1106

NameCVE-2018-1106
DescriptionAn authentication bypass flaw has been found in PackageKit before 1.1.10 that allows users without administrator privileges to install signed packages. A local attacker can use this vulnerability to install vulnerable packages to further compromise a system.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4207-1
NVD severitylow
Debian Bugs896703

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
packagekit (PTS)jessie1.0.1-2fixed
stretch (security), stretch1.1.5-2+deb9u1fixed
bullseye, sid, buster1.1.12-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
packagekitsource(unstable)1.1.10-1896703
packagekitsourcejessie(not affected)
packagekitsourcestretch1.1.5-2+deb9u1DSA-4207-1
packagekitsourcewheezy(not affected)

Notes

[jessie] - packagekit <not-affected> (Issue introduced later)
[wheezy] - packagekit <not-affected> (Issue introduced later)
http://www.openwall.com/lists/oss-security/2018/04/23/3
Fixed by: https://github.com/hughsie/PackageKit/commit/7e8a7905ea9abbd1f384f05f36a4458682cd4697 (PACKAGEKIT_1_1_10)
Introduced by: https://github.com/hughsie/PackageKit/commit/f176976e24e8c17b80eff222572275517c16bdad
Resulting affected (upstream) versions: >= 1.0.10 up until current 1.1.9

Search for package or bug name: Reporting problems