CVE-2018-1112

NameCVE-2018-1112
Descriptionglusterfs server before versions 3.10.12, 4.0.2 is vulnerable when using 'auth.allow' option which allows any unauthenticated gluster client to connect from any network to mount gluster storage volumes. NOTE: this vulnerability exists because of a CVE-2018-1088 regression.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
glusterfs (PTS)stretch3.8.8-1fixed
buster5.5-3fixed
bullseye9.2-1fixed
bookworm, sid9.3-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
glusterfssource(unstable)(not affected)

Notes

- glusterfs <not-affected> (Fix for CVE-2018-1088 was not applied/ incomplete fix not applied)
https://bugzilla.redhat.com/show_bug.cgi?id=1570891

Search for package or bug name: Reporting problems