CVE-2018-1120

NameCVE-2018-1120
DescriptionA flaw was found affecting the Linux kernel before version 4.17. By mmap()ing a FUSE-backed file onto a process's memory containing command line arguments (or environment strings), an attacker can cause utilities from psutils or procps (such as ps, w) or any other program which makes a read() call to the /proc/<pid>/cmdline (or /proc/<pid>/environ) files to block indefinitely (denial of service) or for some controlled time (as a synchronization primitive for other attacks).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1423-1
NVD severitylow (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)jessie3.16.56-1+deb8u1vulnerable
jessie (security)3.16.57-2vulnerable
stretch4.9.110-1fixed
stretch (security)4.9.110-3+deb9u3fixed
buster4.17.14-1fixed
sid4.17.17-1fixed
linux-4.9 (PTS)jessie (security)4.9.110-3+deb9u2~deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)4.16.12-1low
linuxsourcestretch4.9.107-1low
linux-4.9sourcejessie4.9.110-1~deb8u1lowDLA-1423-1

Notes

http://www.openwall.com/lists/oss-security/2018/05/17/1
https://www.qualys.com/2018/05/17/procps-ng-audit-report-advisory.txt
Fixed by: https://git.kernel.org/linus/7f7ccc2ccc2e70c6054685f5e3522efa81556830

Search for package or bug name: Reporting problems