CVE-2018-11218

NameCVE-2018-11218
DescriptionMemory Corruption was discovered in the cmsgpack library in the Lua subsystem in Redis before 3.2.12, 4.x before 4.0.10, and 5.x before 5.0 RC2 because of stack-based buffer overflows.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1396-1, DSA-4230-1
NVD severityhigh (attack range: remote)
Debian Bugs901495

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
redis (PTS)jessie2:2.8.17-1+deb8u5vulnerable
jessie (security)2:2.8.17-1+deb8u6fixed
stretch3:3.2.6-3+deb9u2fixed
stretch (security)3:3.2.6-3+deb9u1fixed
buster, sid5:4.0.11-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
redissource(unstable)5:4.0.10-1high901495
redissourcejessie2:2.8.17-1+deb8u6highDLA-1396-1
redissourcestretch3:3.2.6-3+deb9u1highDSA-4230-1

Notes

https://github.com/antirez/redis/issues/5017
http://antirez.com/news/119

Search for package or bug name: Reporting problems