CVE-2018-11237

NameCVE-2018-11237
DescriptionAn AVX-512-optimized implementation of the mempcpy function in the GNU C Library (aka glibc or libc6) 2.27 and earlier may write data beyond the target buffer, leading to a buffer overflow in __mempcpy_avx512_no_vzeroupper.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: local)
Debian Bugs899070

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
glibc (PTS)jessie (security), jessie2.19-18+deb8u10vulnerable
stretch2.24-11+deb9u3vulnerable
stretch (security)2.24-11+deb9u1vulnerable
buster, sid2.27-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
eglibcsource(unstable)(unfixed)medium
glibcsource(unstable)2.27-4low899070

Notes

[stretch] - glibc <no-dsa> (Minor issue, can be fixed along in future DSA or point update)
[jessie] - glibc <no-dsa> (Minor issue, can be fixed along in future DSA or point update)
https://sourceware.org/bugzilla/show_bug.cgi?id=23196

Search for package or bug name: Reporting problems