CVE-2018-11307

NameCVE-2018-11307
DescriptionAn issue was discovered in FasterXML jackson-databind 2.0.0 through 2.9.5. Use of Jackson default typing along with a gadget class from iBatis allows exfiltration of content. Fixed in 2.7.9.4, 2.8.11.2, and 2.9.6.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1703-1, DSA-4452-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jackson-databind (PTS)jessie2.4.2-2+deb8u4vulnerable
jessie (security)2.4.2-2+deb8u8fixed
stretch2.8.6-1+deb9u4vulnerable
stretch (security)2.8.6-1+deb9u5fixed
buster2.9.8-3fixed
bullseye, sid2.9.9.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jackson-databindsource(unstable)2.9.8-1high
jackson-databindsourcejessie2.4.2-2+deb8u5highDLA-1703-1
jackson-databindsourcestretch2.8.6-1+deb9u5highDSA-4452-1

Notes

https://github.com/FasterXML/jackson-databind/issues/2032
https://github.com/FasterXML/jackson-databind/commit/27b4defc270454dea6842bd9279f17387eceb737

Search for package or bug name: Reporting problems