CVE-2018-11499

NameCVE-2018-11499
DescriptionA use-after-free vulnerability exists in handle_error() in sass_context.cpp in LibSass 3.4.x and 3.5.x through 3.5.4 that could be leveraged to cause a denial of service (application crash) or possibly unspecified other impact.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs900182

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libsass (PTS)stretch3.4.3-1fixed
bullseye, sid, buster3.5.5-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libsasssource(unstable)3.5.5-3high900182
libsasssourcestretch(not affected)

Notes

[stretch] - libsass <not-affected> (Vulnerability introduced in 3.4.7 upstream)
https://github.com/sass/libsass/issues/2643
https://github.com/sass/libsass/commit/84eaca254ca726531def3569c990089b3154e640

Search for package or bug name: Reporting problems