CVE-2018-1160

NameCVE-2018-1160
DescriptionNetatalk before 3.1.12 is vulnerable to an out of bounds write in dsi_opensess.c. This is due to lack of bounds checking on attacker controlled data. A remote unauthenticated attacker can leverage this vulnerability to achieve arbitrary code execution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4356-1
NVD severityhigh
Debian Bugs916930

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
netatalk (PTS)stretch (security), stretch2.2.5-2+deb9u1fixed
buster3.1.12~ds-3fixed
bookworm, bullseye3.1.12~ds-8fixed
sid3.1.12~ds-9fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
netatalksourcestretch2.2.5-2+deb9u1DSA-4356-1
netatalksource(unstable)2.2.6-2916930

Notes

https://bugzilla.samba.org/show_bug.cgi?id=13711

Search for package or bug name: Reporting problems