CVE-2018-11627

NameCVE-2018-11627
DescriptionSinatra before 2.0.2 has XSS via the 400 Bad Request page that occurs upon a params parser exception.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby-sinatra (PTS)stretch1.4.7-5fixed
buster2.0.5-4fixed
bullseye, sid2.0.8.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby-sinatrasource(unstable)(not affected)

Notes

- ruby-sinatra <not-affected> (Vulnerable code not present)
https://github.com/sinatra/sinatra/issues/1428
Introduced by: https://github.com/sinatra/sinatra/commit/8f8df53ff29938ace79b31097c27d9cdac803b44
Fixed by: https://github.com/sinatra/sinatra/commit/12786867d6faaceaec62c7c2cb5b0e2dc074d71a

Search for package or bug name: Reporting problems