CVE-2018-11685

NameCVE-2018-11685
DescriptionLiblouis 3.5.0 has a stack-based Buffer Overflow in the function compileHyphenation in compileTranslationTable.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
liblouis (PTS)jessie2.5.3-3+deb8u1vulnerable
stretch3.0.0-3+deb9u4fixed
buster3.8.0-2fixed
bullseye, sid3.10.0-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
liblouissource(unstable)3.5.0-3medium
liblouissourcestretch3.0.0-3+deb9u4medium

Notes

[jessie] - liblouis <no-dsa> (Minor issue)
https://github.com/liblouis/liblouis/issues/593
https://github.com/liblouis/liblouis/commit/b5049cb17ae3d15b2b26890de0e24d0fecc080f5

Search for package or bug name: Reporting problems