CVE-2018-11697

NameCVE-2018-11697
DescriptionAn issue was discovered in LibSass through 3.5.4. An out-of-bounds read of a memory region was found in the function Sass::Prelexer::exactly() which could be leveraged by an attacker to disclose information or manipulated to read from unmapped memory causing a denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libsass (PTS)stretch3.4.3-1vulnerable
buster, sid3.5.5-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libsasssource(unstable)(unfixed)medium

Notes

[stretch] - libsass <no-dsa> (Minor issue)
https://github.com/sass/libsass/issues/2656

Search for package or bug name: Reporting problems