CVE-2018-11710

NameCVE-2018-11710
Descriptionsoundlib/pattern.h in libopenmpt before 0.3.9 allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted AMS file because of an invalid write near address 0 in an out-of-memory situation.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libopenmpt (PTS)stretch0.2.7386~beta20.3-3+deb9u3vulnerable
buster0.4.3-1fixed
bullseye, sid0.4.11-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libopenmptsource(unstable)0.3.9-1

Notes

[stretch] - libopenmpt <no-dsa> (Minor issue)
https://lib.openmpt.org/libopenmpt/2018/04/29/security-updates-0.3.9-0.2-beta32-0.2.7561-beta20.5-p9-0.2.7386-beta20.3-p12/
https://source.openmpt.org/browse/openmpt/trunk/?op=revision&rev=10149&peg=10150

Search for package or bug name: Reporting problems