CVE-2018-11751

NameCVE-2018-11751
DescriptionPrevious versions of Puppet Agent didn't verify the peer in the SSL connection prior to downloading the CRL. This issue is resolved in Puppet Agent 6.4.0.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs952925

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
puppet (PTS)jessie (security), jessie3.7.2-4+deb8u1vulnerable
stretch4.8.2-5vulnerable
buster5.5.10-4vulnerable
bullseye, sid5.5.19-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
puppetsource(unstable)(unfixed)952925

Notes

[buster] - puppet <no-dsa> (Minor issue)
[stretch] - puppet <no-dsa> (Minor issue)
[jessie] - puppet <ignored> (Patch too invasive to backport, minor issue)
https://puppet.com/security/cve/CVE-2018-11751/
https://tickets.puppetlabs.com/browse/PUP-9459
https://github.com/puppetlabs/puppet/commit/b49c11b6425738441d6f33285d2630fa434a123e

Search for package or bug name: Reporting problems