CVE-2018-11775

NameCVE-2018-11775
DescriptionTLS hostname verification when using the Apache ActiveMQ Client before 5.15.6 was missing which could make the client vulnerable to a MITM attack between a Java application using the ActiveMQ client and the ActiveMQ server. This is now enabled by default.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs908950

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
activemq (PTS)jessie5.6.0+dfsg1-4+deb8u3vulnerable
jessie (security)5.6.0+dfsg1-4+deb8u2vulnerable
stretch5.14.3-3vulnerable
buster, sid5.15.8-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
activemqsource(unstable)5.15.6-1low908950

Notes

[stretch] - activemq <no-dsa> (Minor issue)
[jessie] - activemq <no-dsa> (Minor issue)
http://activemq.apache.org/security-advisories.data/CVE-2018-11775-announcement.txt
https://git-wip-us.apache.org/repos/asf?p=activemq.git;a=commit;h=bde7097fb8173cf871827df7811b3865679b963d
https://git-wip-us.apache.org/repos/asf?p=activemq.git;a=commit;h=02971a40e281713a8397d3a1809c164b594abfbb
Fixed in 5.15.6

Search for package or bug name: Reporting problems