CVE-2018-11798

NameCVE-2018-11798
DescriptionThe Apache Thrift Node.js static web server in versions 0.9.2 through 0.11.0 have been determined to contain a security vulnerability in which a remote user has the ability to access files outside the set webservers docroot path.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs918734

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
thrift (PTS)buster, sid0.11.0-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
thriftsource(unstable)0.11.0-4unimportant918734

Notes

https://issues.apache.org/jira/browse/THRIFT-4647
https://github.com/apache/thrift/commit/2a2b72f6c8aef200ecee4984f011e06052288ff2
src:thrift in Debian configured with --without-nodejs

Search for package or bug name: Reporting problems